Win a copy of Head First Agile this week in the Agile forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Simple dynamic expression evaluation not working  RSS feed

 
Kezia Matthews
Ranch Hand
Posts: 107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
I am new to JSP. Was trying out an example with java expression. I am not getting the evaluated expression in the output.
As preliminary steps, I have done the following.
- I have installed jdk; set the PATH variable to contain the bin sub directory, also set the CLASSPATH to point to the current directory.
- I have installed a Blazix web server and made it ruuning before executing my code.
The code is as follows being stored in the 'webfiles' directory under Blazix directory. The name of the file given is jsptest.jsp.
<HTML>
<BODY>
The time is now <%= new java.util.Date() %>
</BODY>
</HTML>
The jsp file when run displays only the text and not the evaluated expression.
Can anybody tell me whether I am missing out anything??
Thanks.
Kezia.
 
Anand Ko
Ranch Hand
Posts: 79
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
1) The same piece of code works on Tomcat.
I just doubt u gave the right extension?.
 
Kezia Matthews
Ranch Hand
Posts: 107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I have given the extension .jsp
Can anybody help me on this?
Regards.
Kezia.
 
Kezia Matthews
Ranch Hand
Posts: 107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
I am new to JSP. Was trying out an example with java expression. I am not getting the evaluated expression in the output.
As preliminary steps, I have done the following.
- I have installed jdk; set the PATH variable to contain the bin sub directory, also set the CLASSPATH to point to the current directory.
- I have installed a Blazix web server and made it ruuning before executing my code.
The code is as follows being stored in the 'webfiles' directory under Blazix directory. The name of the file given is jsptest.jsp.
<HTML>
<BODY>
The time is now <%= new java.util.Date() %>
</BODY>
</HTML>
The jsp file when run displays only the text and not the evaluated expression.
Can anybody tell me whether I am missing out anything??
Thanks.
Kezia.
 
Kezia Matthews
Ranch Hand
Posts: 107
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi All,
Can anybody help me in regard to my question? I think, I am missing out some setting that has to be done to get the jsp running. Unless I track down the problem, I won't be able to proceed any further....Could any of the JSP experts out there kindly help me out?
Thanks,
Kezia.
[ December 08, 2003: Message edited by: Kezia Matthews ]
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66208
151
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't believe that there are many here who are familiar with the Blazix server. Were you using Tomcat, I'm sure you'd have gotten more responses.
In any case, this is clearly a server setup issue and not a JSP problem per se, so I'm moving it along to the Other Java Servers Forum.
bear
 
Jeremy Davis
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm not familiar with that server, but since its an app server I'd suggest checking to make sure your config files are set to handle .jsp's.
 
rahul bivalkar
Greenhorn
Posts: 16
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
I am trying to run the EJBs on the following website:
http://www.fawcette.com/javapro/2003_01/online/j2ee_bkurniawan_01_09_03/default_pf.aspx

Everything works fine until i try to test the EJB using the Client application

I am running JBoss4.0.1 and JDK 1.4.2

I get the following errors.

C:\workplace>java -classpath C:\jboss\jboss-4.0.1sp1\client\jboss-client.jar;C:\
jboss\jboss-4.0.1sp1\client\jnp-client.jar;. Client "golden retriever"
Exception in thread "main" java.lang.NoClassDefFoundError: org/jboss/logging/Log
ger
at org.jnp.interfaces.NamingContext.<clinit>(NamingContext.java:104)
at org.jnp.interfaces.NamingContextFactory.getInitialContext(NamingConte
xtFactory.java:41)
at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:6
62)
at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:243
)
at javax.naming.InitialContext.init(InitialContext.java:219)
at javax.naming.InitialContext.<init>(InitialContext.java:195)
at Client.main(Client.java:25)

-----------------------------------------------------------

I do not know what is going on. All help is appreciated

thanks in advance
rahul
 
Mohammad Hoque
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
use C:\jboss\jboss-4.0.1sp1\client\jbossall-client.jar instead of jboss-client.jar
 
Ernest Friedman-Hill
author and iconoclast
Sheriff
Posts: 24217
38
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Boy,this is a weird thread. It starts out being about JSPs, and the forum it's in (Other Java Products) is the wrong one. Then someone, two years later, posts a question about EJBs in it; this is still the wrong forum. I'm going to move this thread -- putting it to rest here, at last -- to the EJBs forum.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!