• Post Reply Bookmark Topic Watch Topic
  • New Topic

ejb3.0 in jboss?

 
lee jiang
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,guys!

i 'm a learner in Java EE. i would like to deploy an EJB3.0 application into jboss-4.0.3SP1,and have installered it with the graphical installer .when it runs ,the question appears:

Caused by: java.lang.ClassNotFoundException: Unexpected error during load of: org.jboss.ejb3.EJB3Deployer, msg=org/jboss/ejb3/EJB3Deployer ( Unsupported major.minor version 49.0)

why?
thanks !
jiang

[ December 28, 2005: Message edited by: lee jiang ]
[ December 28, 2005: Message edited by: lee jiang ]
 
Mark Spritzler
ranger
Sheriff
Posts: 17290
9
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"NOTE: EJB 3.0 can be installed by choosing "Run Installer" or by downloading and running jboss-4.0.3SP1-installer.jar."

I saw this under the download for that JBoss version.

Maybe you don't have the ejb3 jar file and deployer in your JBoss server directory. I assume you are running the default server, so go into the deploy directory for that part and see if you see the ejb3 jar and deployer stuff.

Mark
 
lee jiang
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
yeah, they've been there!

maybe i should rerun the jboss-4.0.3SP1-installer.jar?

tkank you ,mark!

jiang
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!