• Post Reply Bookmark Topic Watch Topic
  • New Topic

'Head first EJB' development environment  RSS feed

 
Chakravarthy Rajagopalan
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I want to try out the exercises in Head First EJB First edition released i October 2003. I currently have a Windows XP environment of J2SE Dev Kit 5.0 Update 2, J2SE Runtime 5.0 Update 2, Sun App server PE 8, and NetBeans IDE 4.1.

Is this environment good enough or should i download a better Java environment to try out the EJB exercises of the book ?

Thanks.
 
Mark Spritzler
ranger
Sheriff
Posts: 17309
11
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You have the most recent version of Java, how can there be something better out there? You also need the J2EE jar files too, from Sun.

Mark
 
Jeroen T Wenting
Ranch Hand
Posts: 1847
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
those jars are contained in the Sun Appserver, there's no longer a standalone distribution of them like there was with J2EE 1.3.

You will want to get ANT and probably JUnit as well at some point, but AFAIK that's not needed for following the book.

Personally I don't like Netbeans but the choice of code editor is irrelevant to the technology. You would rather be better off using a regular text editor which forces you to think and code rather than push buttons and fill in some forms to get your code generated for you.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!