• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

Problem: Sharing session between two different Web browser & Web Applications

 
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I�m facing a strange scenario here and would appreciate any inputs which could resolve this issue.

I have two webapplications (EAR�s) on two different machine and different WebSphere application server. I have �WebAppA� [on machine A, WAS A] which opens in parent window and expects to pass some info in the FORM submission with request parameter to �WebAppB� [on machine B, WAS B] which opens in a child window browser on clicking submit button from �WebAppA�.

Now the WebAppA is required to wait till the response come from WebAppB after certain functionality and once the function of retrieval is over by WebAppB, it sent back the response data back to WebAppA FORM, which finally submits this form after getting the response data from WebAppB. Now the response to WebAppA [which is in machine A, WAS A] from WebAppB is a pure POST request on complete URL and set of request parameters with values.

Now what is happening is that, when a User A fills the form on WebAppA and submits the data to WebAppB, on response it gets the data of some other User request, for example day of UserB or UserC.

Now when I do the test on my development environment, where its just me or some other 2-3 users accessing it I don�t face any problem. I get the response for the request I have submitted�.PERFECT. On production I have issue where users are getting data as response of other users.

I suspect since the response is submitted to the form page of WebAppA its unable to synchronize to which user it belongs to. May be that�s the reason when I test it on development with single or 2-3 users its behaving fine. I hope I could put my question properly to you. I don�t know what can resolve this or what is the actual cause? Is there a proper way to implement this? Please any suggestion or inputs are appreciated.
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
    Bookmark Topic Watch Topic
  • New Topic