Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

JMS Character Set Error  RSS feed

 
Paul O'Neill
Ranch Hand
Posts: 40
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am getting the following error when I pick up messages from an MQ queue. I have charsets.jar AND I've tried i18.jar in my classpath and it makes no difference. I don't get the error if I publish the message from my desktop or if I retrieve the message through WSAD on my desktop. I only get the error when I run the subscribing software from a Windows 2000 testing server. So it's like something on my testing server does not like messages coming from the mainframe.

This used to work!
The changes I've made lately are using jre 1.4.2_13 isntead of an old IBM JRE and I'm using a WMQInitialContextFactory ainstead of a WSNInitialContextFactory. I have included all the mq jar files I was told to include.

Any ideas on where I can look next? I'm completely stumped.

Thanks!!


JMS Message class: jms_text
JMSType: null
JMSDeliveryMode: 2
JMSExpiration: 0
JMSPriority: 0
JMSMessageID: ID:c3e2d840d8d4f5f24040404040404040c078d1de7d841540
JMSTimestamp: 1177013594040
JMSCorrelationID:null
JMSDestination: null
JMSReplyTo: null
JMSRedelivered: true
JMS_IBM_PutDate:20070419
JMSXAppID DALSEAT
JMS_IBM_Format:MQSTR
JMS_IBM_PutApplType:2
JMS_IBM_MsgType:8
JMSXUserID DALSEA
JMS_IBM_PutTime:20131404
JMSXDeliveryCount:7
<Exception occurred reading message body: javax.jms.MessageFormatException: MQJMS1046: The character set Cp037 is not supported><null>
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!