Win a copy of Head First Android this week in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

j2ee command is not working

 
Ranch Hand
Posts: 47
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I have installed j2ee 1.3.1 Sdk from sun web site http://java.sun.com/j2ee/sdk_1.3/... But, j2ee command is not working even if i have set up J2EE_HOME, JAVA_HOME, PATH env variable. It is strange, I am not able to correct it myself. Please help me asap.

C:\Documents and Settings\Administrator>j2ee -verbose
'C:\Program' is not recognized as an internal or external command,
operable program or batch file.

C:\Documents and Settings\Administrator>j2ee -start
'C:\Program' is not recognized as an internal or external command,
operable program or batch file.
C:\Documents and Settings\Administrator>

These are env variable values

J2EE_HOME = C:\j2sdkee1.3.1
JAVA_HOME= C:\Program Files\Java\jdk1.5.0_03
PATH = C:\Program Files\Java\jdk1.5.0_03\bin;C:\j2sdkee1.3.1\bin;

I have restarted my CMD prompt. I have been trying since past 3 days. Please help me asap. javascript: x()
banghead

Thanks,
Sarav !
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
"Saravvij"

Please check your private message, for a message from JavaRanch.
 
Jaikiran Pai
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

JAVA_HOME= C:\Program Files\Java\jdk1.5.0_03
PATH = C:\Program Files\Java\jdk1.5.0_03\bin



There have been many cases where you see weird problems, when Java is installed in a folder containing a space in its path. In your case, you have Java installed in C:\Program Files which has a space in its path. Move you Java folder to some other path which does not have a space in its path (maybe C:\Java) and change the JAVA_HOME and PATH appropriately to point to this new folder. Then run the command.
[ August 08, 2007: Message edited by: Jaikiran Pai ]
 
Saravanan Vijayappan
Ranch Hand
Posts: 47
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Amazing !!

Your Idea worked. Thank you very much !!
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic