• Post Reply Bookmark Topic Watch Topic
  • New Topic

Cannot use EJB3 in Netbeans 5.5.1 & 6.0.1

 
Calson LI
Ranch Hand
Posts: 42
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all,

I installed the following components in sequence at home in my home notebook with Windows XP O.S.
1. Unzip JBoss 4.2.2.GA to C:\JBoss 4.2.2.GA
2. Install JDK 1.5.0_15
3. Install JDK 1.4.2_17
4. Set JAVA_HOME to C:\Program files\Java\JDK 1.5.0_15
5. Install Netbeans 5.5.1 with Java EE
6. Add JBoss 4.2.2.GA in Netbeans server section

I failed to create an Enterprise Application with Java EE 5 (i.e. EJB3) because it only gives me J2EE 1.4 (i.e. EJB2) during project creation process. The same happens for Netbeans 6.0.1

The strange things is that I can create EJB3 with Netbeans 5.5.1 in my office computer even if it only get JDK 1.5.0_06 and JDK 1.4.2_16.

Could anyone give me some advice?

Many thanks,
Calson

 
Syed Saifuddin
Ranch Hand
Posts: 130
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Calson

JBoss 4.2.2 is not a fully Java EE 5 Server so this support is not there.
SO if you want to use JBoss then download JBoss5 beta
 
John Gregory
Ranch Hand
Posts: 118
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I had a similar experience with this. If JBoss 4.2.2 is
compatible, then could someone explain why i have a printout
of a netbeans tutorial that indicated it did? The date on
my print out was last July. However, the JBoss version used
in the tutorial was 4.0.x, (I don't have the handout in front
of me). If I have to go to JB-5, then ok. I was just curious
why Netbeans seemed to imply it was j2ee-5 compatible.

Thanks,

John
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!