• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Ron McLeod
  • Junilu Lacar
  • Liutauras Vilda
Sheriffs:
  • Paul Clapham
  • Jeanne Boyarsky
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Piet Souris
  • Carey Brown
Bartenders:
  • Jesse Duncan
  • Frits Walraven
  • Mikalai Zaikin

Problem with using Jboss

 
Ranch Hand
Posts: 45
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I am using my Jboss Application Serer (Version: 4.2.2.GA) to run my JMS application. As long as I am using "jnp://localhost:1099", it works, but when I change localhost to the IP address ("jnp://132.205.93.311:1099") of the same machine, it gives me the following error. I also changed the jndi.properties like this:


Code:



Error :
javax.naming.CommunicationException: Could not obtain connection to any of these urls: 132.205.93.31:1099 and discovery failed with error: javax.naming.CommunicationException: Receive timed out [Root exception is java.net.SocketTimeoutException: Receive timedout] [Root exception is javax.naming.CommunicationException: Failed to connect to server 132.205.93.31:1099 [Root exception is javax.naming.ServiceUnavailableEx
ception: Failed to connect to server 132.205.93.31:1099 [Root exception is java.net.ConnectException: Connection refused: connect]]]
 
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

change props.put(Context.PROVIDER_URL, "jnp://132.205.93.311:1099"); to props.put(Context.PROVIDER_URL, "132.205.93.311");

Is should work ! In JBoss you are not suppose to use JNP and port number.

Cheers,
Sunil
 
Sheriff
Posts: 10445
227
IntelliJ IDE Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Amir Pourteymour:

I am using my Jboss Application Serer (Version: 4.2.2.GA) to run my JMS application. As long as I am using "jnp://localhost:1099", it works, but when I change localhost to the IP address ("jnp://132.205.93.311:1099") of the same machine, it gives me the following error.



How are you starting JBoss? I guess, you are not using the -b option while starting JBoss. Start JBoss with the -b option as explained here
 
reply
    Bookmark Topic Watch Topic
  • New Topic