This week's book giveaway is in the Jython/Python forum.
We're giving away four copies of Murach's Python Programming and have Michael Urban and Joel Murach on-line!
See this thread for details.
Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

problem in deploying the EJB into the WebSphere app server  RSS feed

 
Gayathri Chowduru
Ranch Hand
Posts: 42
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Everyone,

I am very new to this EJB. I have developed a simple EJB application and deployed it into the WebSphere app server. It has shown the message like "Successfully deployed". I am using the MyEclipse Blue. After starting the server, in the logs I am getting a message like

"naming exception caused the creation of the home obj to fail"

Can anybody please tell me what is the problem and why I am getting this message?

Thaks,
Gayathri
 
Scott Selikoff
author
Bartender
Posts: 4081
21
Eclipse IDE Flex Google Web Toolkit
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is the error actually related to a problem you're having? J2EE servers often log numerous messages on startup, many of which are not vital to application functionality.
 
Roger Chung-Wee
Ranch Hand
Posts: 1683
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What usually happens is that there is a failure in doing an InitialContext lookup for the Home stub. Check that the JNDI name which you are using in your lookup is the same as the one which you have deployed with the EJB.
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!