• Post Reply Bookmark Topic Watch Topic
  • New Topic

RemoteException after EJB call  RSS feed

Timothy Sam
Ranch Hand
Posts: 751
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi guys,

I've been trying to solve this for two days...

I'm calling a remote EJB(stateless) from another EJB(also stateless). I'm using RAD7, so under the assembly tab of the deployment descriptor, I created an entry under container transactions with type of Not Supported. Now, I can all the remote EJB, but after the method completes I receive a remote(which I wrapped so the message below won't show it) exception saying...

[5/21/08 12:37:09:133 CST] 00000034 LocalTranCoor W WLTC0033W: Resource jdbc/DB_APP_SOURCE

rolled back in cleanup of LocalTransactionContainment.

[5/21/08 12:37:09:164 CST] 00000034 LocalTranCoor W WLTC0032W: One or more local

transaction resources were rolled back during the cleanup of a LocalTransactionContainment.
PatternLayout "21/05/2008 12:37:09 DEBUG: EXIT: SearchManagerDelegate.searchByPO()
" PatternLayout "21/05/2008 12:37:09 ERROR:
" com.myapp.ejb.session.exception.SearchManagerException:

javax.transaction.TransactionRolledbackException: CORBA TRANSACTION_ROLLEDBACK 0x0 No; nested

exception is:

javax.transaction.TransactionRolledbackException: ; nested exception is:
com.ibm.websphere.csi.CSITransactionRolledbackException: vmcid: 0x0 minor code: 0

completed: No

I tried changing the transaction type but I still get the same exception. Having no transaction type defined results in a time out.
[ May 20, 2008: Message edited by: Timothy Sam ]
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!