Win a copy of Head First Android this week in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

EJB 3.0 look up throw naming exception

 
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi,

I just started learning ejb 3.0. I downloaded jboss 4.0.5 AS and downloaded EJB3Trail from jboss trailblazer. When I deployed it by copying the EJB3Trail.ear file in the default/deploy directory of jboss. I tried running the calculator example and got a naming not found exception.

After reading some blogs it seems we have install jboss with a installer and not just zip.So i installed jboss4.0.4 with the installer, but the problem is still there.. This is driving me crazy.. I have no idea why this is happening and not to say about the jboss documentation..

Please help me out..

Thanks,
Gopi
 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
i think you need to install ejb3 using jems installer...

or you can use jboss 4.2.2 (it comes with ejb3 support)

thanks,
Sameer P
 
Gopi Chand
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi Sameer,

thanks for your reply.when we install jboss,it give some installation profiles.. i selected all, do i have to select ejb3?
 
sameer ravindra
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
yes you have to use.... ejb3( or ejb3 clustering..if you want) with jdk 5.0....( applicable to jboss 4.04)

thanks,
Sameer P
 
Gopi Chand
Greenhorn
Posts: 24
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
i installed jboss 4.2.3 and everything worked fine..

i don't know why installing and configuring jboss is always difficult for new guys.. why don't jboss release a specific version of jboss a complete zip file with everything.. no configuration should be required, atleast minimal..
it should allow have a default db configuration packed (not Hypersonic one).. probably mysql.. getting even the basic configuration working is taking lot of time, searching and head banging..

Do you guys feel the same or it is just because i am lazy?

is something like that already there??
 
You showed up just in time for the waffles! And this tiny ad:
Building a Better World in your Backyard by Paul Wheaton and Shawn Klassen-Koop
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
reply
    Bookmark Topic Watch Topic
  • New Topic