• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Tim Cooke
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Knute Snortum
  • paul wheaton
  • Devaka Cooray
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Ron McLeod
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Tim Holloway
  • Carey Brown
  • salvin francis

jdk 1.3 on NT 4 compiling problems, please help

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am using jdk 1.3(bundled with jbuilder personal edition 5) on NT, Tomcat, Struts and Oracle JDBC to develop an application.
I have included a "." at the end of my classpath configuration, however, the compiler refused to read anything in the current directory. Not even when I use "import ..." to explicitly include the classes in the same package(directory). Seems DC Dalton had the same problem on Windows 2000. I tried to copy the working directory into the classpath, still doesn't work.
Any body had the same problem before, your timely input will be deeply appreciated.
 
author
Posts: 621
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You probably have a couple of classes/packages with the same name in you classpath. This seem to happen a lot with oracle and xml packages for some reason. It also seems to reveal itself if you use a dot in your classpath. Try putting the dot at the begining of the classpath or, better yet, remove it altogether and specify the dot when you run the application
java -classpath $CLASSPATH:. MyApp
Hope this helps.
Sean
 
yeah, but ... what would PIE do? Especially concerning this tiny ad:
Java file APIs (DOC, XLS, PDF, and many more)
https://products.aspose.com/total/java
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!