• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

javac running slow

 
Pradeep bhatt
Ranch Hand
Posts: 8933
Firefox Browser Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi all,
I am not sure whether this is right place to post my problem.
I need ur help to solve the problem of slow javac.
The javac compiler in m/c is running very slow. It takes about 5 minutes to compile a file. This problem started only recently but before it was working fine. Strangely the java comand executes quickly.
Reinstalling JDK did not help.
My machine has 256 MB RAM , P III processor and runs on windows 2000.
 
Roger Thornhill
Author
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You might want to post the version of Java you're running and your CLASSPATH. Five minutes to compile a file is a bit long!
 
Jim Yingst
Wanderer
Sheriff
Posts: 18671
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
And does it take this long to compile any Java file, or is there a particular file that it's got problems with? If the latter - is there anything else unusual about this file?
You might also want to look at the Windows Task Manager to see what your CPU and memory usage are during compilation. This can help provide clues...
 
Pradeep bhatt
Ranch Hand
Posts: 8933
Firefox Browser Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The javac is slow for any file, how ever small it is.I am using JDk 1.3.1.I switched now to 1.4 but with no difference.
The memory usage for javac fluctuates between 600k to 2000k.(captured from Task manager).
Some one please help me.
[ May 20, 2002: Message edited by: Pradeep Manjeshwar ]
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What is your classpath setting?
 
Ashok Mash
Ranch Hand
Posts: 1936
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I know this is NOT the right solution for your problem, still let me add it here.
Using Jikes instead of javac is much faster, especially when you have dozens of packages to be compiled in a go.
Again, coming back to the strange behaviour of javac in your machine, you should try de-installing (complete wipe-out of all traces of jdk/jre etc) and then a fresh install. A complete de-install is more important that you imagine.
Good Luck!
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic