• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Jeanne Boyarsky
  • Devaka Cooray
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Knute Snortum
  • Bear Bibeault
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • Piet Souris
  • Ganesh Patekar
Bartenders:
  • Frits Walraven
  • Carey Brown
  • Tim Holloway

JTable problem in different JDKs

 
Ranch Hand
Posts: 160
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Our swing application is written and running smoothly in JDK1.2.2 (developed in VAJ) and now we tried to run the same app in JRE1.4
We have a JTable and we have a custom model class which extends from DefaultTableModel and implements PropertyChangeListener. This custom table model allows us to have row based approach.
When we run on JDK1.4, we get NullpointerException - getColumnCount() null , getRowCount() null.
I tried commenting the code to create the rows.It is creating the colums as below:

But the same stuff running fine in JDK1.2.2.
Thanks in Advance.
Thanks
Sri
 
Consider Paul's rocket mass heater.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!