• Post Reply Bookmark Topic Watch Topic
  • New Topic

error when i run the code  RSS feed

 
sagarika chinya
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am writing a program to implement a B+ tree GUI interface. All the classes are compiling but when try to run my main class btview i am getting the following error. i am new to java,could any body explain as to whats going wrong??
thanks
sagarika
Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
at <Unloaded Method>
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:124)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:63)
at <Unloaded Method>
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:124)
at java.awt.Toolkit$2.run(Toolkit.java:499)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.getDefaultToolkit(Toolkit.java:492)
at java.awt.Window.getToolkit(Window.java:432)
at nodeContent.<init>(nodeContent.java:54)
at btview.main(btview.java:25)
 
Josh Rehman
Ranch Hand
Posts: 63
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah, I can tell you at least one thing that's wrong: you didn't post the code!
 
qs Wang
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
are you use the os linux or unix ?you should do the follow before run your program : export DISPLAY = <ip>:0.0 (<ip> is the IP of your host)
 
vinaya kumar
Ranch Hand
Posts: 70
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ur DISPLAY value is wrong..
check for exact value of ur display card number(0.0)
Hope this helps
vinaya
 
Don't get me started about those stupid light bulbs.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!