• Post Reply Bookmark Topic Watch Topic
  • New Topic

HELP NEEDED ON APPLET & ICONS: Loading icon files from JAR file

 
Rolf Moholth
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Here's my problem:
I'm currently loading icons into my APPLET from GIF and JPEG files. These files are loaded from the applet JAR file.
However: On Friday I installed Service Pack 3 for my Win2000. At that point, the following strange thing happened:
(1) I can still load the icon files I generated BEFORE my SP3 update
(2) I am NOT able to load any icon files I generated AFTER that unfortunate SP3 update
(3) If a make a copy of a GIF file made from BEFORE the SP3 update - THIS COPY DOES NOT LOAD FROM THE JAR FILE EITHER!
I'm feeling a bit ....
I'd really like to avoid to copy the icon files down to the server. I need to keep them in my JAR file to (a) Save FLASH storage, (b) Make things a bit easier to maintain...
Can anyone shed some light or add to my confusion?
Regards, Rolf
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Welcome to JavaRanch, Rolf!
That sounds like a strange and frustrating problem in deed.
When you're speaking of Windows 2000 and the SP3 installation, is it correct to assume that this is the OS running on the client that is having the problem?
Any chance you could post an example Applet on a server some place that others could take a look at and let you know of their experiences?
 
Rolf Moholth
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Dirk Schreckmann:
Welcome to JavaRanch, Rolf!
That sounds like a strange and frustrating problem in deed.
When you're speaking of Windows 2000 and the SP3 installation, is it correct to assume that this is the OS running on the client that is having the problem?
Any chance you could post an example Applet on a server some place that others could take a look at and let you know of their experiences?

Thanks for the response, Dirk!
Yes, you're correct in that the client is running the Win2000 SP3, and I suspect that there is some kind of problem with the comibation Win2000 SP3, JBuilder 6.0, JRE 1.4.0-beta3. When I view the JAR file on the PC, I can see all my icon files there with proper names and directories and all. But the my "ImageLoader" class cannot find it. I have so far settled for actually installing the GIF files on the server, but I would really like to avoid that. It makes updating the JAVA code much harder.
About the server: I have tried the applet in several ways: (1) Running from JBuilder- icons&jar works OK , (2) Running by double-clicking the HTML-file on my PC - icons&jar does NOT WORK , (3) Serving the Applet from a Apache server running on my PC - icons&jar does NOT WORK ,
and finally (4) Serving the Applet from the HTTP server on my NETOS based embedded system - icons&jar does NOT WORK
The applet itself cannot be used on any server, it's for an embedded system and requires that system to run properly. I'll try to make a simpler version of the applet that only illustrates the icon problem.
Regards, Rolf
 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You didn't mention it in your post... so I just have to make sure... You are loading your icons with some code like:


Right?
[ April 01, 2003: Message edited by: Nathan Pruett ]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!