Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

JEditor not displaying unicode ↔  RSS feed

 
Chris-Huisman
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
I am using JEditorPane to display HTML documents in my application. The application reads the html page and sets that as the content of the JEditorPane.
My problem is that I am trying to display a double arrow (&harr using "↔" but instead of displaying the double arrow, it writes out "&harr" to the screen. My content type is set to "text/html", and characters like "<" and ">" print out <, and >. How do I get "&harr" to print a double arrow?
thanks,
c.
 
Chris-Huisman
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
ok that message didn't come out exactly how I wanted it to. I have typed & h a r r into my web page. This should write out a double arrow ↔, but instead it writes out the & h a r r. & l t and & g t write out < >, why won't & h a r r write out ↔?
c.
 
Chantal Ackermann
Ranch Hand
Posts: 508
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
a wild guess: maybe the editor just doesn't have the type sign for it? maybe if you try out different fonts?
if you haven't done that anyway, yet: a look into the java bugparade (or more generally through google) might show whether other people had similar problems.
regards,
Chantal
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!