Win a copy of Murach's Python Programming this week in the Jython/Python forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

Minimum JDK version to test the codes in Desktop Java Live  RSS feed

 
Ko Ko Naing
Ranch Hand
Posts: 3178
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Scott,
I am starting a new thread, since I feel that this question might be useful for those who are interested in your book and it is essential to know this.

I just would like to know which JDK version should be used to compile and run the codes available in the book. For the safe side, we could use the latest JDK 1.5, but, u know, for those who do not have that version readily installed on the machine, will JDK 1.4 be alright for the codes?
 
Scott Delap
author
Ranch Hand
Posts: 73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
JDK 1.4 will be fine for everything but the Synth examples which require 1.5. While I haven't tried it, I think 99% of the code would also work with 1.3 even. JGoodies Forms, Validation, and Binding are 1.3+ compatible I think as are Foxtrot and Spin.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!