• Post Reply Bookmark Topic Watch Topic
  • New Topic

jdk 1.5 updation and swings  RSS feed

 
yam murali
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi ,

We have updated from jdk1.3 to JDK1.5, it's a standalone application with the GUI developed in swings .On compilation we are getting errors like incompatable types certain comboboxes require com.sun.java where as certain require javax.swing .Do we have to add any more jar files?
 
Nathan Pruett
Bartender
Posts: 4121
IntelliJ IDE Java Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Could you post the exact errors you are getting, including the class names?

It could be a corrupted install of the 1.5 JDK that has messed up class libraries, or it could be something that changed between JDK 1.3 and 1.5.

The javax.swing package is included in the JDK, and the classes and methods in this package should be guaranteed to be the same across releases (things can be added, but not removed, only deprecated) so this possibly points to a bad JDK install.

The com.sun.java package is also included in the JDK, but the specific classes and methods in these packages aren't guaranteed to remain the same across JDK releases.

It's possible that something changed in these packages that you'll need to change between JDK 1.3 and 1.5... but it could just be a bad JDK install also. Can't really know until exact class names are provided.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!