Win a copy of Learning OpenStack Networking: Build a solid foundation in virtual networking technologies for OpenStack-based clouds this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
  • Devaka Cooray
Sheriffs:
  • Jeanne Boyarsky
  • Knute Snortum
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Ganesh Patekar
  • Stephan van Hulst
  • Pete Letkeman
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Ron McLeod
  • Vijitha Kumara

JSP with IIS 3.0 and JRUN 3.0 concocts a peculiar problem  RSS feed

 
Ugly Redneck
Ranch Hand
Posts: 1006
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a very peculiar problem. I have developed a JSP application which has to run under IIS 3.0 with the JRUN plugin. The JSP makes use of a bean, and the bean is placed inside a package. Whenever the JSP is called, the JSP functions but I receive the error that the package cannot be located.
I tried placing the bean in the root directory and then I received the error that the Bean could not be found. I have tried everything. However the same JSP and bean, run fine under JSWDK and Java Webserver 2.0, as well as Forte
Any solutions???
Thanks in advance
Sriraj Rajaram
 
Author and all-around good cowpoke
Rancher
Posts: 13078
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Probably JRun has a different convention about classes used in multiple applications. In 2.3, it is the lib directory but I don't know what it is in 3.0. Read the documentation or browse around until you find a bunch of jar files.
Bill
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!