• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

servlet...SSI

 
chandu raja
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi There,
Could anyone tell me if Apache webserver supports SSI. I have apache webserver/tomcat server running, now my apache webserver is not detecting <SERVLET> tag and as a result the SSI module in the shtml page is not getting parsed.
I have Apache WebServer 1.3.14 and tomcat server 3.2
could you help me please
Thanks
 
Randall Twede
Ranch Hand
Posts: 4489
3
Java Python Scala
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I just found out recently that Apache has an add-on product for this called ApacheJSSI 1.1.2 . I downloaded it from somewhere on their site but havent unzipped it yet.
 
chandu raja
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Randall...
Thanks
for the reply...I am still searching for the JSSI
RT
 
chandu raja
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Randall,
I couldn't find anything called ApacheJSSI on their website http://jakarta.apache.org/site/binindex.html
I have only find this site only....could you tell where did you find it...thanks
in advance..
RT
 
Randall Twede
Ranch Hand
Posts: 4489
3
Java Python Scala
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I will try to find it for you.
It is at http://java.apache.org/
[This message has been edited by Randall Twede (edited January 23, 2001).]
 
chandu raja
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The Install file specifies that Apache JSSI can only be installed on Apache Jserv as servlet engine...but I have a tomcat...it does't give any notes on how it can be done on TOMCAT Engine...
Anyways thanks for your tip...
RT
 
chandu raja
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Randall,
I found the Apache JSSI at http://java.apache.org/ and I want to let you know that... but finally couldn't install because I hnave a tomcat server and I don't where to find the file zone.properties
 
Randall Twede
Ranch Hand
Posts: 4489
3
Java Python Scala
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
darn! I thought it would work with Tomcat which is what I have also. I will read the instructions again.
 
chandu raja
Greenhorn
Posts: 18
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Randall,
Any update...
thanks
RT
 
Randall Twede
Ranch Hand
Posts: 4489
3
Java Python Scala
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I havent tried it yet but this is what the installation instructions say:
Install it like any other servlet and map the *.jhtml-extension to be handled with this servlet.
Requirements
Any servlet engine compatible with the 2.0 Servlet API specification (the use of Apache JServ is highly recommended). Note that the JSDK 2.1 isn't supported yet and the SSI servlet may or may not work with JSDK 2.1 compliant servlet engines.
Any Java 1.1 compatible compiler
So it should work with Tomcat
One way to find out
This configuration stuff hurts my brain
It looks like it might be the tomcat.properties file in \jakarta-tomcat\conf directory

[This message has been edited by Randall Twede (edited January 25, 2001).]
[This message has been edited by Randall Twede (edited January 25, 2001).]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic