• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Please help -- Urgent

 
Divyajot Ahluwalia
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dear Friends,
I am having a peculiar problem. I am making a web application using servlets and jdbc. I have been writing code using jdbc for a long time now. I have win98 office 2000, jdk1.2,jsdk and use the access2000 db for development. I have recently installed mysql including the gui tool and the mysql driver and mysql.
Ever since this installation none of my applications are working with the access2000 based file dsn. i am still using the same code
Class.forName("sun.jdbc.odbc.JdbcOdbcDriver");
Connection c=DriverManager.getConnection("jdbc dbc:refer","","");
the moment the second statement is executed the jre throws and error(illegal operation)and shuts down.
Does this situation mean that the installation of mysql drivers have overridden the previous access driver?? will i need to reinstall office 2000?
Pl advice... Im in some sort of a soup becoz of this
Thanks a ton in advance
Divyajot
 
Saran Vel
Ranch Hand
Posts: 111
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I haven't worked in MySql, but make sure u have defined u'r datasource name and related the driver with that dsn. This can be done by settings.. If u'r operating system is win2000 go to settings-->controlpanel-->Administrative Tools-->Data Sources and check for the driver and dsn.
And one more thing.. in the following, is the dsn u defined is typo error..?
Connection c=DriverManager.getConnection(<b>"jdbc dbc:refer"</b>,"","");
But shuld be like
Connection c=DriverManager.getConnection(<b>"Jdbc:Odbc:refer"</b>,"","");
Regards
Saran
 
Divyajot Ahluwalia
Ranch Hand
Posts: 46
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
thank you saran,
yes its a typo.....
see what has happened is that i was doing all my development weth access2000 and everything was working fine. then i installed mysql and my odbc. since then even my prevoius programmes are not working. the file dns are still the same( i have double checked it...)
I have since then starting working with mysql and its own drivers and it is working properly now.
Is it possible that installing mysql/ myodbc has corrupted the access drivers???
what do you think i should do?
thanks in advance
Divyajot
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic