• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JSP is not Running under JRun --Pl Help Me

 
Ramesh Subramanian
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello, I'm having windows'98, JRun, Jre1.2.2.007. I can able to run servlet pgms. But i couldn't able to run JSP programs. even the example pgm given by the Jrun Management console (ie) MyFirstJspPage.jsp It gives the following error:
The code for MyFirstJspPage is:
<html>
<head>
<title>Greetings</title>
</head>
<body>
<% for(int i=0;i<5;i++) { %>
<h1>Hello World!</h1>
<% } %>
</body>
</html>
while Running it gives the following error.
404 Not Found
/MyFirstJspPage.jsp:

allaire.jrun.JRunServletException: The page /MyFirstJspPage.jsp could not be found.
at allaire.jrun.jsp.JSPParser.generateXML(JSPParser.java:56)
at allaire.jrun.jsp.JSPServlet.parsePage(JSPServlet.java:409)
at allaire.jrun.jsp.JSPServlet.createServlet(JSPServlet.java:381)
at allaire.jrun.jsp.JSPServlet.loadPage(JSPServlet.java:202)
at allaire.jrun.jsp.JSPServlet.service(JSPServlet.java:169)
at allaire.jrun.servlet.JRunSE.service(JRunSE.java:1013)
at allaire.jrun.servlet.JRunSE.runServlet(JRunSE.java, Compiled Code)
at allaire.jrun.servlet.JRunRequestDispatcher.forward(JRunRequestDispatcher.jav a:88)
at allaire.jrun.servlet.JRunSE.service(JRunSE.java:1131)
at allaire.jrun.servlet.JvmContext.dispatch(JvmContext.java:330)
at allaire.jrun.http.WebEndpoint.run(WebEndpoint.java:107)
at allaire.jrun.ThreadPool.run(ThreadPool.java, Compiled Code)
at allaire.jrun.WorkerThread.run(WorkerThread.java, Compiled Code)
I followed all the steps correct.
I stored in default-app dir.and the url like http://localhost:8100/MyFirstJspPage.jsp
Can you pl tell me whether i need to set any classpath.
I'm having JRE in c:\prgramfiles\java soft. pl explain me how to solve the problem?
Thanks in Advance.
Ramesh
 
Gaurav Chikara
Ranch Hand
Posts: 412
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
set your classpath to whatever jar files u have in your JRun
this is a very simple classpath problem
or either u have not placed jsp file properly
or u r trying to access it with wrong name
 
Ramesh Subramanian
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
what are all the softwares i should have to run JSP?
1.default_exports.jar
2.default_objects.jar
3.ejipt.jar
4.ejipt_client.jar
5.ejipt_ejbeans.jar
6.ejipt_jms_client.jar
7.ejipt_tools.jar
8.install.jar
9.jrun.jar
10.jsp.jar
11.jsprt.jar
12.rhino.jar
13.ssi.jar
14.wddx.jar
15.xt.jar
These are the jar files found under lib dir
Shall i include all of them in the class path.
 
Gaurav Chikara
Ranch Hand
Posts: 412
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi
I think simply include jsp.jar
I used javawebserver2.0 and included servlets.jar
and it worked perfectly

Originally posted by Ramesh Subramanian:
what are all the softwares i should have to run JSP?
1.default_exports.jar
2.default_objects.jar
3.ejipt.jar
4.ejipt_client.jar
5.ejipt_ejbeans.jar
6.ejipt_jms_client.jar
7.ejipt_tools.jar
8.install.jar
9.jrun.jar
10.jsp.jar
11.jsprt.jar
12.rhino.jar
13.ssi.jar
14.wddx.jar
15.xt.jar
These are the jar files found under lib dir
Shall i include all of them in the class path.

 
Ramesh Subramanian
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i included that jsp.jar
Again it gives the same error.
 
Tim Smith
Greenhorn
Posts: 19
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What version of Jrun are you using?
 
Ramesh Subramanian
Greenhorn
Posts: 13
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm having JRun 3.0
In which directory should i have JRE?
I'm having that on c:\programfiles\java soft.
Actually what JSP program does whlie compiling?
where it will search in JRE?
PL help me to come out of this hell.
 
Angela Lamb
Ranch Hand
Posts: 156
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This sounds like a simple problem of not having your JSP file in the right place. Make sure that your web directory is set properly.
In the JRun Management Console, go to
Web Applications - Default User Application
This will show what your root directory is. If it isn't the right folder, just click on the 'Edit Application' icon to change it.
HTH
 
padmshree Patil
Ranch Hand
Posts: 54
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
Try by placing ur JSP file in
Allaire\JRun\servers\default\default-app directory.

-
padmashree
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic