Win a copy of Programmer's Guide to Java SE 8 Oracle Certified Associate (OCA) this week in the OCAJP forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Netscape servlet woes

 
Joe Wolf
Ranch Hand
Posts: 42
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am testing an authentication scheme that creates a http session value called "login.isDone" To protect a servlet, I have them check to see if this session value is non-null. If it is null, it redirects the user to a login page, otherwise it displays html to the authenticated user. The login page posts the user name and pass to a servlet which compares the values to those in a database and sets the login.isDone value if the pair is present.
This set-up is working fine in IE5.1 but when I try using Netscape Communicator 4.7, I have problems.
When I try to access the protected servlet the first time, Netscape correctly redirects me to the login page. When I input incorrect login information, Netscape correctly calls the login servlet which then tells me my login information was wrong. But when I put in the correct login information and hit submit, Netscape either sends me immediately back to the login page or occasionally pops up this notice dialog saying "No data to post".
What gives? How can I work around this problem? Any help apprectiated...thanks.
-Joe
 
Joe Wolf
Ranch Hand
Posts: 42
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I just tried the servlets out on Netscape Communicator 4.67 and they worked. Perhaps this is just a Netscape 4.6 bug or something.
 
Joe Wolf
Ranch Hand
Posts: 42
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I mean, "4.76" and "4.7"
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic