• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Jeanne Boyarsky
  • Tim Cooke
Sheriffs:
  • Bear Bibeault
  • Henry Wong
  • Devaka Cooray
Saloon Keepers:
  • salvin francis
  • Tim Moores
  • Tim Holloway
  • Stephan van Hulst
  • Frits Walraven
Bartenders:
  • Jj Roberts
  • Carey Brown
  • Scott Selikoff

Links to jsp/beans not working in JWS 2.0!

 
Greenhorn
Posts: 2
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
My jsp files are invoked/displyed without any problem when I open them in the browser using both jswdk-1.0.1 and JWS2.0. In jswdk, everything works perfectly, but when I click on the the links or Submit buttons of the jsp files which are displayed in JWS , I get an error -
Error during JSP page processing
java.lang.NoSuchMethodError: java.lang.System: method setProperty(Ljava/lang/String;Ljava/lang/String Ljava/lang/String; not found
at
at IDRClient.Functions.(Functions.java:63)
at java.beans.Beans.instantiate(Beans.java:120)
at pagecompile.jsp._registrars._add._add._jspService(_add.java:95)
at com.sun.server.http.pagecompile.jsp.runtime.HttpJspBase.service(HttpJspBase.java:87)
at javax.servlet.http.HttpServlet.service(Compiled Code)
at com.sun.server.http.pagecompile.jsp.runtime.JspServlet.runServlet(JspServlet.java:469)
at com.sun.server.http.pagecompile.jsp.runtime.JspServlet.processJspPage(JspServlet.java:259)
at com.sun.server.http.pagecompile.jsp.runtime.JspServlet.service(JspServlet.java:97)
at javax.servlet.http.HttpServlet.service(Compiled Code)
at com.sun.server.ServletState.callService(ServletState.java:226)
at com.sun.server.ServletManager.callServletService(ServletManager.java:936)
at com.sun.server.ProcessingState.invokeTargetServlet(ProcessingState.java:423)
at com.sun.server.http.HttpProcessingState.execute(HttpProcessingState.java:79)
at com.sun.server.http.stages.Runner.process(Runner.java:79)
at com.sun.server.ProcessingSupport.process(Compiled Code)
at com.sun.server.Service.process(Service.java:204)
at com.sun.server.http.HttpServiceHandler.handleRequest(HttpServiceHandler.java:374)
at com.sun.server.http.HttpServiceHandler.handleRequest(Compiled Code)
at com.sun.server.HandlerThread.run(Compiled Code)

The methos setProperty exists in the mentioned files, so I can't figure out what the problem is. The set Property method contains -
System.setProperty("java.protocol.handler.pkgs",
"com.sun.net.ssl.internal.www.protocol");
Security.addProvider(new com.sun.net.ssl.internal.ssl.Provider());

The same links work perfectly in jswdk server, but not in JWS2.0!!! I tried to modify the java.security file also, but then the JWS server couldn't start. I was told that this has something to do with JRe version of JWS, which is 1.1.7. If I upgraded the JRE to 1.2.2, the method is supported in that. But I tried replacing the jre folder in jws with the new version, I got an error -
Program c:\JavaWeb~1.0\bin\..\jre\bin\jre.exe exited with code -1073741819
c:\JavaWeb~1.0\bin\..\bin\jserv.exe
c:\JavaWeb~1.0\bin\..\bin\jserv.exe
jserv: Shutting down the server
Also, I cannot start the jws server from the command prompt using -javahome option, as I get an error -
Can't read file 'c:\JavaWebServer2.0\bin\..\keys'.
Provider did not return PKCS8Key
Program c:\JDK12~1.2\bin\java.exe exited with code 1
c:\JavaWeb~1.0\bin\..\bin\jserv.exe
c:\JavaWeb~1.0\bin\..\bin\jserv.exe
Could someone tell me how to rectify these??? Please help!
 
Roses are red, violets are blue. Some poems rhyme and some don't. And some poems are a tiny ad.
the value of filler advertising in 2021
https://coderanch.com/t/730886/filler-advertising
reply
    Bookmark Topic Watch Topic
  • New Topic