Win a copy of Succeeding with AI this week in the Artificial Intelligence and Machine Learning forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
  • Junilu Lacar
Sheriffs:
  • Tim Cooke
  • Jeanne Boyarsky
  • Knute Snortum
Saloon Keepers:
  • Stephan van Hulst
  • Tim Moores
  • Tim Holloway
  • Carey Brown
  • Piet Souris
Bartenders:
  • salvin francis
  • fred rosenberger
  • Frits Walraven

my first servlet - help!

 
Greenhorn
Posts: 23
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm running an eval copy of Weblogic 6.0.
I've successfully built and deployed an example.
When putting in my url 'http://127.0.0.1:7001/HelloServlet/'
I get no response.
I'm running Windows2000, is there some settings I need
to check in my browser, Explorer?
Thanx in advance!
Mark
 
Ranch Hand
Posts: 254
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
try http://127.0.0.1:7001/servlet/HelloServlet
Beksy
[This message has been edited by Beksy Kurian (edited October 05, 2001).]
 
Ranch Hand
Posts: 216
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, there is nothing to check on your browser. I think that you are typinng the right URL because you are not getting a '404 error saying that the page cannot be found. What is your servlet supposed to do anyway? Is it outputing any text onto the browser because that is the best way to test? Just a thought, in Tomcat we use 'http://127.0.0.1:7001/servlet/HelloServlet/' to run servlets and I'm not sure how WebLogic works.

Your port is 7001: try to change it back to 80 and try again.

Keep trying anyway and u should be able to crack it soon.

[This message has been edited by ernest fakudze (edited October 05, 2001).]
 
Ranch Hand
Posts: 130
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is there any servlets directory in ur server.. then u should keep the .java file in that directory and after compilation in browser write:
http://localhost/servlet/HelloServlet
Pranit..

Originally posted by Mark Jutras:
I'm running an eval copy of Weblogic 6.0.
I've successfully built and deployed an example.
When putting in my url 'http://127.0.0.1:7001/HelloServlet/'
I get no response.
I'm running Windows2000, is there some settings I need
to check in my browser, Explorer?
Thanx in advance!
Mark


 
Ranch Hand
Posts: 93
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to register your servlet in weblogic.properties file. In that file you are going to specify classpath to your servlet as well as servlet mapping. I have forgotten how to do that, but it is quite nicely explained in weblogic documentation.
 
Your buns are mine! But you can have this tiny ad:
Two software engineers solve most of the world's problems in one K&R sized book
https://coderanch.com/wiki/718759/books/Building-World-Backyard-Paul-Wheaton
    Bookmark Topic Watch Topic
  • New Topic