• Post Reply Bookmark Topic Watch Topic
  • New Topic

Custom tags and JRUN 3.1

 
vincenzo del borrello
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
I have a jsp that use custom tag and it runs correctly under JRUN 3.0
When I tried to run the same jsp under JRUN 3.1 it doesn't work.
The error message is:
_________________________________________
500 Internal Server Error
/structure_locator/send.jsp:
Parse Error in JSP page: The custom tag 'TagMail' on line '73' of page '/common/include/ask_submit_read_parameter.inc' is missing the required attribute 'recipient'.
allaire.jrun.jsp.ParseException: The custom tag 'TagMail' on line '73' of page '/common/include/ask_submit_read_parameter.inc' is missing the required attribute 'recipient'.
at allaire.jrun.jsp.JSPParser.validateTagAttributes(../jsp/JSPParser.java:500)
at allaire.jrun.jsp.JSPParser.action(../jsp/JSPParser.java:1194)
at allaire.jrun.jsp.JSPParser.parse(../jsp/JSPParser.java:925)
at allaire.jrun.jsp.JSPParser.writeXML(../jsp/JSPParser.java:135)
at allaire.jrun.jsp.JSPParser.includeDirective(../jsp/JSPParser.java:746)
at allaire.jrun.jsp.JSPParser.directive(../jsp/JSPParser.java:968)
at allaire.jrun.jsp.JSPParser.parse(../jsp/JSPParser.java:921)
at allaire.jrun.jsp.JSPParser.writeXML(../jsp/JSPParser.java:135)
at allaire.jrun.jsp.JSPParser.generateXML(../jsp/JSPParser.java:107)
at allaire.jrun.jsp.JSPParser.generateXML(../jsp/JSPParser.java:51)
at allaire.jrun.jsp.Translator.parsePage(../jsp/Translator.java:192)
at allaire.jrun.jsp.Translator.translate(../jsp/Translator.java:390)
at allaire.jrun.jsp.Translator.translate(../jsp/Translator.java:92)
at allaire.jrun.jsp.JSPTranslator.translate(../jsp/JSPTranslator.java:75)
at allaire.jrun.jsp.JSPTranslator.translate(../jsp/JSPTranslator.java:67)
at allaire.jrun.jsp.JSPServlet.service(../jsp/JSPServlet.java:216)
at allaire.jrun.jsp.JSPServlet.service(../jsp/JSPServlet.java:196)
at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1416)
at allaire.jrun.session.JRunSessionService.service(../session/JRunSessionService.java:1082)
at allaire.jrun.servlet.JRunSE.runServlet(../servlet/JRunSE.java:1270)
at allaire.jrun.servlet.JRunRequestDispatcher.forward(../servlet/JRunRequestDispatcher.java:89)
at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1552)
at allaire.jrun.servlet.JRunSE.service(../servlet/JRunSE.java:1542)
at allaire.jrun.servlet.JvmContext.dispatch(../servlet/JvmContext.java:364)
at allaire.jrun.jrpp.ProxyEndpoint.run(../jrpp/ProxyEndpoint.java:388)
at allaire.jrun.ThreadPool.run(../ThreadPool.java:272)
at allaire.jrun.WorkerThread.run(../WorkerThread.java:75)
_________________________________________
I have checked "everything", but I don't know where the mistake is!
Thanks, Vincenzo
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!