• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Weblogic servlet error

 
Mal Vik
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi everyone,
I am struggling with this weird form of error that I have not been able to resolve. I am getting this null ppointer exception on a line(64) that has no nulls. I verified this by checking the values. Even though I am getting this error, the application performs normally, successfully downloads a file in this case. I have deployed my application on Weblogic 6.1 SP3.Can anyone throw some light on this?
Thanks in advance.
<Aug 13, 2002 2:42:16 PM EDT> <Error> <HTTP> <[WebAppServletContext(1031797,Defa
ultWebApp,/DefaultWebApp)] Servlet failed with Exception
java.lang.NullPointerException
at DownloadServlet.service(DownloadServlet.
java:64)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:265)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubIm
pl.java:200)
at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppSe
rvletContext.java:2546)
at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestIm
pl.java:2260)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:139)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:120)
>
[ August 13, 2002: Message edited by: malla6um ]
 
Dave Vick
Ranch Hand
Posts: 3244
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
malla6um
Welcome to the Java Ranch, we hope you�ll enjoy visiting as a regular however,
your name is not in keeping with our naming policy here at the ranch. Please change your display name to an appropriate name as shown in the policy.
Thanks again and we hope to see you around the ranch!!
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic