• Post Reply Bookmark Topic Watch Topic
  • New Topic

Servlet version compatibility  RSS feed

 
frank davis
Ranch Hand
Posts: 1479
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My company was considering buying an existing Servlet application that uses Oracle as the DB. The application is 3 years old. Should Servlets be assumed to be backward compatible if we move the exsiting application to a new server using the latest Servlet specs?
We don't know the current version of Servlets being used.
 
Chris Mathews
Ranch Hand
Posts: 2712
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There have been some major changes in the Servlet API since 2.1 (it is now at 2.3 with 2.4 soon to follow). If the application is at least written using Servlets 2.2 then I would say you are fine. Regardless, do some testing on your own and ask the company that wrote the application if they have tested under later versions of the Servlet API.
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13078
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You also need to consider the Java runtime version that the application was written for versus what the server provides.
I understand that SDK 1.4 has some changes to the database APIs that are incompatible with programs written for earlier JDKs.
You should download the servlet API from java.sun.com - it has a changes section that may help.
Bill
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!