Win a copy of Learning OpenStack Networking: Build a solid foundation in virtual networking technologies for OpenStack-based clouds this week in the Cloud/Virtualization forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Liutauras Vilda
  • Campbell Ritchie
  • Tim Cooke
  • Bear Bibeault
  • Devaka Cooray
Sheriffs:
  • Jeanne Boyarsky
  • Knute Snortum
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Ganesh Patekar
  • Stephan van Hulst
  • Pete Letkeman
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Ron McLeod
  • Vijitha Kumara

server not starting  RSS feed

 
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi all..

I am new to Servlet programming.I installed jdk1.2.1 and jsdk2.1 on my machine.
I created a HelloServlet program and compiled it by appropriately setting the classpath..

i tried to start the server by the following

c:/jsdk2.1/>startserver.

but when i tried http://localhost:8080 in internet explorer,
i couldn't get anything..

Please anyone help me out..

Thanks in advance,
Regards,
Rajani.
 
Ranch Hand
Posts: 149
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The j2sdkx.xx is only one of the requirements to develop JSP and Servlet. You also need a servlet container.Now which one are you using? :roll:
 
Rajani Sudhakar
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi..

Let me be clear..

I installed jdk1.1.8 and Tomacat4.1.30.
I have set the environment variables as follows:

set JAVA_HOME=c:\jdk1.1.8
set CATALINA_HOME=c:\ jakarta-tomcat-4.1.30

when i start the server , i get a syntax error as follows"

c:\jakarta-tomcat-4.1.30\bin>startup
Syntax error
Using CATALINA_BASE: ..
Using CATALINA_HOME: c:\jakarta-tomcat-4.1.30
Using CATALINA_TMPDIR: ..\temp
Using JAVA_HOME: c:\jdl1.1.8

A window is displayed and disappears in no time.

HOw can i fix this?

Thanks in advance,
Regards,
Rajani.

 
Author and ninkuma
Marshal
Posts: 66797
168
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Perhaps you should read what you posted carefully:

Using CATALINA_BASE: ..
Using CATALINA_HOME: c:\jakarta-tomcat-4.1.30
Using CATALINA_TMPDIR: ..\temp
Using JAVA_HOME: c:\jdl1.1.8



And JDK 1.1.8? Are you also using a chisel and tablet to write the code?
 
Greenhorn
Posts: 5
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Rajani Sudhakar:
Hi all..

I am new to Servlet programming.I installed jdk1.2.1 and jsdk2.1 on my machine.
I created a HelloServlet program and compiled it by appropriately setting the classpath..

i tried to start the server by the following

c:/jsdk2.1/>startserver.

but when i tried http://localhost:8080 in internet explorer,
i couldn't get anything..

Please anyone help me out..

Thanks in advance,
Regards,
Rajani.



I don't know what your really trying to do but if you want any off the disk drives you woyld have to use:

<A HREF="file:///C:/jsdk2.1/>startsever."></A>

And if that doesn't work you can always "run" the program.
 
Rajani Sudhakar
Ranch Hand
Posts: 60
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
OOPS !
Sorry....

That was a typing mistake ...
it wasn't jdl1.18 but its jdk1.1.8

but i get the same syntax error

rajani.
 
Greenhorn
Posts: 4
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Rajani,
When U set the path of TOMCAT server to CATALINA make sure that u r setting the path in CATALINA_HOME...OK??? also check that all the files r being uninstalled and set the class path to the CATALINA_HOME"...

thank you, with regards,
raja
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!