• Post Reply Bookmark Topic Watch Topic
  • New Topic

deployment descriptor - classpath problem

 
Babar Qadri
Ranch Hand
Posts: 51
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Deployment descriptor below is working fine on windows machine.



have changed it for Linux, below



And it is not working. The reason behind might be, "It is taking these paths as relative paths, but actually i tried to give absolute paths". Both starts with a slash "/" in linux. So, how to differ?

Kindly help me, folks.


Note: I just did that because of suckin JasperReport
[ March 15, 2005: Message edited by: Babar Qadri ]
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Those are legitimate, absolute paths in Linux.

Out of curiosity, what are you trying to do with a classpath in a webapp?
 
Babar Qadri
Ranch Hand
Posts: 51
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks Ben,

JasperReport API checks for "jasper.reports.compile.class.path" as system property, but couldn't find this in my case. Raised exception as a result. Therefore, I did something like below inside my servlet and it is working fine on windows machine.



What do you mean by "legitimate absolute path"?

How to differ between relative and absolute path in linux or unix, as both starts with a slash "/"?

And how to solve it?
[ March 15, 2005: Message edited by: Babar Qadri ]
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!