• Post Reply Bookmark Topic Watch Topic
  • New Topic

How to detect which Servlet API version is being used?  RSS feed

 
James Hodgkiss
Ranch Hand
Posts: 401
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Does anyone know if there is an easy way to determine which version of the Servlet API is being used?

The reason is that I have a context listener which isn't working on a particular server and I'm wondering if it is because it isn't using the Servlet 2.3 API.

Thanks,
James
 
Vijay Kiran
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You might need to check the server documentation.

Check if this can help

http://www.stanford.edu/group/coursework/stanfordoki/oreilly/com.oreilly.servlet.VersionDetector.html
 
Vijay Kiran
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You can download cos.jar from this location

http://servlets.com/cos/
 
James Hodgkiss
Ranch Hand
Posts: 401
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
That's just the job - thanks very much for this.
 
Vijay Kiran
Greenhorn
Posts: 21
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
James,

Be sure to read the license in case you want to use cos.jar in commercial app.


Regards,
Vijay
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!