Win a copy of Head First Android this week in the Android forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Tim Cooke
  • Campbell Ritchie
  • Paul Clapham
  • Ron McLeod
  • Liutauras Vilda
Sheriffs:
  • Jeanne Boyarsky
  • Rob Spoor
  • Bear Bibeault
Saloon Keepers:
  • Jesse Silverman
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
Bartenders:
  • Piet Souris
  • Al Hobbs
  • salvin francis

Session timeout settings (JRun4)

 
Ranch Hand
Posts: 115
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hi All,

We are using JRun4 as Application Server. We have to set the session time to 8 hours rather default 30 mins.

I tried setting the session time out in web.xml and jrun.xml, but still the session is expiring in 30 mins.

We installed Updater 5 for JRun4 also but no difference.

Please help.Its very urgent...

regards,
Shalini
 
Ranch Hand
Posts: 2874
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Have you tried setMaxInactiveInterval()??

[Edited]
I mean httpSession.setMaxInactiveInterval()
[ September 01, 2005: Message edited by: Adeel Ansari ]
 
Shalini Chandel
Ranch Hand
Posts: 115
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I didn't try that. How to use this method and where exactly I have to put it?
Can you please give some code or something for example.

regards,
Shalini
 
Adeel Ansari
Ranch Hand
Posts: 2874
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Shalini Chandel:
I didn't try that. How to use this method and where exactly I have to put it?
Can you please give some code or something for example.



You can execute this method just after authenticating the user, by getting his/her session. Moreover, you can easily get the session from the request object.

Thanks.
 
Ranch Hand
Posts: 74
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have the same issue before where I didn't want server's default timeout value. So, I added the timeout value in my web.xml and it works just fine. By the way, I run in WAS server.

This is what I have:-



By the way, 8 hours are really a long period of time! May I ask why you plan to do that? In my environment, if I have more than 30 minutes timeout, I will have these security teams come bugging me.
 
Ranch Hand
Posts: 8944
Firefox Browser Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

Originally posted by Adeel Ansari:


You can execute this method just after authenticating the user, by getting his/her session. Moreover, you can easily get the session from the request object.

Thanks.



Why do we need this ? Settings in web.xml should work fine.
 
Shalini Chandel
Ranch Hand
Posts: 115
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Adeel:
Thanx a lot. Its working perfectly. Thanx again.

Choon-Chern Lim:
It is Client's requirement and we didnt ask them why.

Pradip:
It was not working when I modify web.xml. But as suggested by Adeel, It working now. So there might be some issues with JRun4.
 
Pradeep bhatt
Ranch Hand
Posts: 8944
Firefox Browser Spring Java
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator

It was not working when I modify web.xml. But as suggested by Adeel, It working now. So there might be some issues with JRun4.



This should be filed as a bug. I have JRun before and found serveral bugs (e,.g. session.setattribute("key",null) was not working etc)and filed them. It was resolved later.
 
Ranch Hand
Posts: 55
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
hello this question has aroused many folks interest but my question is still waiting for its answer.I guess u guys know how to get it done.pls help me n answer my question which is in the same forum reg deployment of servlet in jrun
thank u in advance
Rajesh chandra
 
reply
    Bookmark Topic Watch Topic
  • New Topic