• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Session Timeout Problem

 
Nitin Dubey
Ranch Hand
Posts: 126
Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,

A single servlet is deployed in tomcat 5.5.9 running with a GET request. The background process that is hit takes 4-5 hrs to complete and in the mean time after 30 mins(default), the browser page displays "Page cannot be displayed" error. After the process is complete I just need to show a msg that "your process is complete"

I have tried web.xml property <session-timeout>-1</session-timeout> but it is not working. Is it because after the first request is sent there is no response back to the browser and the client browser never comes to know the session timeout value.

Suggest me something for this. Let me know if what I am doing is correct or I am getting wrong somewhere.

Cheers,


Nitin
[ October 06, 2005: Message edited by: Mark Spritzler ]
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 65216
95
IntelliJ IDE Java jQuery Mac Mac OS X
 
Nitin Dubey
Ranch Hand
Posts: 126
Oracle
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry Bibeault, if you want I can post this msg again.

nitin
 
David O'Meara
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, but if Bear hadn't posted his comment I would have edited the topic to remove the [URGENT]. You can do this by editing the first post if you like.

A 4-5 hour operation is a problem. We have discussed long operations previously, I'll have a look for some of the threads. You should check the search facilities too if it is urgent.
 
David O'Meara
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
here is one, see the second last post from Peter Bell, ignore the last post

Still looking.
 
Mark Spritzler
ranger
Sheriff
Posts: 17278
6
IntelliJ IDE Mac Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well before I saw the other comments, I edited out the Urgent part in the thread title.

Mark
 
David O'Meara
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
or this from Ben but I think this is the one I was looking for.
 
Sripathi Krishnamurthy
Ranch Hand
Posts: 232
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Try to set the session timeout parameter in tomcat home directory.
Ex:
In the <tomcat home directory>/conf/web.xml
set it as 240 minutes.

<session-config>
<session-timeout>240</session-timeout>
</session-config>
 
David O'Meara
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Mark Spritzler:
Well before I saw the other comments, I edited out the Urgent part in the thread title.


Works for me
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic