• Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other Pie Elite all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Jeanne Boyarsky
  • Ron McLeod
  • Paul Clapham
  • Liutauras Vilda
Sheriffs:
  • paul wheaton
  • Rob Spoor
  • Devaka Cooray
Saloon Keepers:
  • Stephan van Hulst
  • Tim Holloway
  • Carey Brown
  • Frits Walraven
  • Tim Moores
Bartenders:
  • Mikalai Zaikin

Version issue while deploying

 
Ranch Hand
Posts: 190
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I have a new install of Sun App server. When I try to deploy a web module I am getting the following error. I have JDK version 1.5 and JRE version 1.5. I checked under HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft and in Control pannel, Add remove programms.

Unable to load servlet specified in the module.
Please consult online help for assistance.
java.lang.UnsupportedClassVersionError: TestServlet (Unsupported major.minor version 49.0)

Any help appreciated.
Thanks.
 
Sheriff
Posts: 14691
16
Eclipse IDE VI Editor Ubuntu
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Check that your PATH contains the right version of your JRE.
It may be pointing to an older version (it often happens when Oracle is installed)
 
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I got this error when I was using Tomcat 5.0.28 and deployed classes compiled with JDK1.5 , Then recompiled with 1.4.X and this error did not show up.

I guess same thing may be happening in your case, compile your classes with jdk1.4 it may solve your problem.
 
Ranch Hand
Posts: 213
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Use Tomcat 5.5.x. This version is for JRE 5
 
Ranch Hand
Posts: 181
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
Hey

I too got this problem when I tried to use the classes compiled with jre1.5 in jre1.4.

I tried both compilation and running using jdk1.4

Cheers,
Su Yeu.
 
PradeepPillai Pradeep
Ranch Hand
Posts: 190
  • Mark post as helpful
  • send pies
    Number of slices to send:
    Optional 'thank-you' note:
  • Quote
  • Report post to moderator
I tried compiling using C:\Sun\Creator\java\bin\javac.exe and it worked. So I reinstalled sun app server again and it works now.
Thanks for everybody who stepped in.
 
reply
    Bookmark Topic Watch Topic
  • New Topic