Win a copy of Practical SVG this week in the HTML/CSS/JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic

class file has wrong version 48.0, should be 47.0

 
Sooraj Godavarma
Greenhorn
Posts: 6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,

I am using WSAD 5.1.2 and the server is Websphere Test Environment 5.0. We took an API from net which is used for drawing chars and graphs. But this uses JDK 1.4. (javax.nio.ImageIO etc..) or higher. But WSAD 5.1.2 defaults to JDK 1.3. So we went to Window-->Preferences--> Installed JRE's --> and added a new JRE and started pointing to it. Also, we changed JAVA_HOME to point to the new JRE(jre1.4.2_10) but the following error is still there.

The main error is with class file version. May be the server is expecting a diff. version of class file. So I deleted all class files from my web project as well as Java projects and gave a "Rebuild All". Still the error persists.

Can any one help me out in this? Please detail.


D:\MyApp_WORKSPACE\.metadata\.plugins\com.ibm.etools.server.core\tmp0\cache\localhost\server1\MyAppEAR\MyAppWeb.war\myapp\_index.java:4: cannot access org.uss.app.myapp.util.MyKeys

bad class file: D:\MyApp_WORKSPACE\MyAppEAR\MyAppJava.jar(org/uss/app/myapp/util/MyKeys.class)

class file has wrong version 48.0, should be 47.0

Please remove or make sure it appears in the correct subdirectory of the classpath.

[3/10/06 10:25:38:177 IST] 57e857e8 SystemErr R import org.uss.app.myapp.util.MyKeys;

[3/10/06 10:25:38:177 IST] 57e857e8 SystemErr R 1 error

[3/10/06 10:25:38:193 IST] 57e857e8 SystemErr R InsertTag oEndTag caught: javax.servlet.ServletException: Unable to compile class for JSP

[3/10/06 10:25:38:193 IST] 57e857e8 SystemErr R javax.servlet.ServletException: Unable to compile class for JSP
 
dema rogatkin
Ranch Hand
Posts: 294
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
WebSphere using JDK 1.3, so make sure to set -target 1.3 when you use JDK 1.4 for compilation. Use -bootclasspath to add rt.jar from JDK 1.3
 
Anupam Sinha
Ranch Hand
Posts: 1090
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You are using incorrect java version.
 
juan bedoya
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't know if all people now know how to solve this problem, this is what I did and it worked to me:

in websphere window-->preferences-->java-->compiler I select in compliance level: 1.3 and it was all it start to work fine.

Hope this help some one.

Bye
[ October 20, 2006: Message edited by: juan bedoya ]
 
av bharathiraja
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Ranchers.

Im getting the error while running apache ant1.6.1 even after setting PATH, class path, JAVA_HOME system environment variables to jdk1.3. Can anybody help me.
 
Ulf Dittmer
Rancher
Posts: 42970
73
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
av,

your situation may or may not be different from the one mentioned above. if you are using a library that relies on Java 1.4 (like the original poster did), then there is no way you'll get it to work under 1.3.

On the other hand, if it's your own code (and it does not use JDk 1.4-only features), then you should recompile it using the "-target" switch mentioned earlier, or -even better- recompile it using JDK 1.3.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!