Win a copy of The Business Blockchain this week in the Cloud forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

java. lang. UnsupportedClassVersionError:

 
Ronald Mee
Greenhorn
Posts: 15
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Anyone knows what does this error means?

i got this error when trying to run a servlet class from a jsp page
using struts-config

[7/9/07 17:31:45:669 SGT] 1f0102 WebGroup I SRVE0092I: [Servlet
LOG]: action: Error creating Action instance for path '/targetAnnouncement1', class name
'com.ncs.portal.announcement.ctlr.ActTargetAnnouncementTest':
java.lang.UnsupportedClassVersionError:
com/ncs/portal/announcement/ctlr/ActTargetAnnouncementTest (Unsupported major.minor version 49.0)
 
David O'Meara
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It means the class was compiled using Java 5 but is trying to be run using (possibly) Java 1.4
In most cases it is as easy as running the server pointing at Java 5 rather than 1.4
 
David O'Meara
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
"ronron ron",
Welcome to the JavaRanch.

We're a friendly group, but we do require members to have valid display names.

Display names must be two words: your first name, a space, then your last name. Fictitious names are not allowed.

Please edit your profile and correct your display name since accounts with invalid display names get deleted, often without warning

thanks,
Dave
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic