• Post Reply Bookmark Topic Watch Topic
  • New Topic

what is wrong with this DD?  RSS feed

 
Brian Percival
Ranch Hand
Posts: 163
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have a simple:


I just couldn't get the context-param node to work.. while deploying I get a error that it is not valid content. I comment out that node and everything works fine. Pulling my hair for a while. Please help.
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 66260
151
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The error message usually spells out what the validator is unhappy about, so it'd help if you'd show us the details of the error rather than just saying "I get an error".
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Prior to servlet spec 2.4, the order of elements was important.
I'm fairly certain (but check) that context init param elements needed to come before any of the servlet entries.
 
Brian Percival
Ranch Hand
Posts: 163
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Sorry for my late response, was heldup in a meeting since morning.. well, it is to do with the order as Ben mentioned, I should've figured it out myself.

Thanks alot for both of your time.

Brian
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!