• Post Reply Bookmark Topic Watch Topic
  • New Topic

Invoking a new Session  RSS feed

 
Romi Dave
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi I have this problem and hope someone would be able to help me out here. I have two applications. First application has a link to the second application. So from the first application when i click on the link for the second application I would want to initialize all the application related parameters to be set for the second application and a new independent session for the second application to be started. That link from the first application passes few parameters in the url to the second application. Can someone suggest me how i can do it.

Currently the way i have, when i click on the link to second application the request is passed to the second application but the second applications initial parameters are not set and that causes some errors in the second application.

I would appreciate if someone could please suggest me few options to resolve this.

Thanks in advance.
 
Jeanne Boyarsky
author & internet detective
Sheriff
Posts: 36446
454
Eclipse IDE Java VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Romi,
These are two separate applications. You get a new session as you want, but no information is shared automatically. You need to pass something in the link to identify the parameters to the second app. You could either pass all the initialization information or an id that the second app can use to look it up.
 
David O'Meara
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You need to implement 'Single Sign On' (SSO). Your servlet container may have some information for you in its documentation.
 
Romi Dave
Greenhorn
Posts: 26
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi

I am using Struts and Spring framework in my application. Certain beans are initialized using Spring so as you said I did send certain parameters from the first application to the second in the url(link). The request does goto the second application servlet filter but here in second application i get the errors and on debugging i found that beans from the spring config files are not initialized. I confirmed web.xml in the second application and all the spring files are correctly set.
In the second application in servlet filer i also noticed the session is null and so when i go a request.getSession(true) it gets the session from the original application( request from the first application) and my beans for the second application are not initialized.

So any suggestions or tips to resolve this.

On SSO that is being worked out and is in the development pipeline for future releases

Thanks and looking forward to the replies...
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!