• Post Reply Bookmark Topic Watch Topic
  • New Topic

web application error in netbeans

 
Amir Iqbal
Ranch Hand
Posts: 97
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi
can anyone please tell me how can i remove following error... tell me briefly.
paying attention to this post and also reply is encouraged from my side..

regards.
Amir iqbal


Note:
i am so confused coz when i use the same code in a desktop project no error like this generated. but when i try the same code in
JSP-Servlet meanz web application the following error frustrate me...


THE ERROR IS:
C:\Documents and Settings\aamir\Desktop\tryone\src\CompileSourceInMemory.java:35: generics are not supported in -source 1.4

(use -source 5 or higher to enable generics)

DiagnosticCollector<JavaFileObject> diagnostics = new DiagnosticCollector<JavaFileObject>();
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This has nothing to do with Netbeans or webapps.
You're trying to compile something with generics (a 1.5 feature) using a 1.4 compiler.
 
Ben Souther
Sheriff
Posts: 13411
Firefox Browser Redhat VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
i am so confused coz


Please, use only real words when posting to JavaRanch.
 
Muhammad Saifuddin
Ranch Hand
Posts: 1325
Android Java Windows
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
(use - source 5 or higher to enable generics)


you have already answered your question.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!