• Post Reply Bookmark Topic Watch Topic
  • New Topic

Displaying eCards

 
Farakh khan
Ranch Hand
Posts: 833
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I uploaded cards in a directory and the card no is the card name. I simply displayed in the way like:

The problem is that after 2/3 pages it not changes the cards and displaying approximately the old one that already displayed. Where I am wrong
[ September 06, 2008: Message edited by: Farakh khan ]
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65530
108
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please be sure to use UBB code tags when posting code to the forums. Unformatted code is extremely hard to read and many people that might be able to help you will just move along to posts that are easier to read. Please read this for more information.

You can go back and change your post to add code tags by clicking the .
 
Farakh khan
Ranch Hand
Posts: 833
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Bear Bibeault:
Please be sure to use UBB code tags when posting code to the forums. Unformatted code is extremely hard to read and many people that might be able to help you will just move along to posts that are easier to read. Please read this for more information.

You can go back and change your post to add code tags by clicking the .


Thanks for guidance. I edited my post

best regards
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65530
108
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
You really should indent your code. It's hard to read without proper indentation.

What have you done to diagnose this?

For example, have you checked the HTML being sent to the pages so see if the image URLs are updating as expected?
 
Farakh khan
Ranch Hand
Posts: 833
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Bear Bibeault:
You really should indent your code. It's hard to read without proper indentation.

What have you done to diagnose this?

For example, have you checked the HTML being sent to the pages so see if the image URLs are updating as expected?


Yes Sir, I checked the produced HTML as it is ok but pics are not going to be changed. I checked from different browsers. the following is produced HTML that shows different pics:



best regards
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65530
108
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
So you are saying that even though the HTML shows the right image URLs, that the wrong images are being displayed?
 
Farakh khan
Ranch Hand
Posts: 833
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Bear Bibeault:
So you are saying that even though the HTML shows the right image URLs, that the wrong images are being displayed?


ofcourse
 
Bear Bibeault
Author and ninkuma
Marshal
Posts: 65530
108
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
WHat happens if you type those image URLs directly into the address bar? Are they still the old ones. Or do the new ones show up?

How are these URLs resolved? Are they actual files, or are you generating the images on-the-fly?
 
Farakh khan
Ranch Hand
Posts: 833
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Originally posted by Bear Bibeault:
WHat happens if you type those image URLs directly into the address bar? Are they still the old ones. Or do the new ones show up?

How are these URLs resolved? Are they actual files, or are you generating the images on-the-fly?


Are you seeing anything wrong with me code?

kind regards
 
It is sorta covered in the JavaRanch Style Guide.
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!