Win a copy of Svelte and Sapper in Action this week in the JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Ron McLeod
  • Paul Clapham
  • Bear Bibeault
  • Junilu Lacar
Sheriffs:
  • Jeanne Boyarsky
  • Tim Cooke
  • Henry Wong
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • salvin francis
  • Frits Walraven
Bartenders:
  • Scott Selikoff
  • Piet Souris
  • Carey Brown

Problem in Deploying Servlet

 
Greenhorn
Posts: 7
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
I am trying to deploy Servlet in Websphere Application Server V4.0 AES.I created MyServlet.ear using AAT.Created Servlet web component.I have added only one servlet.Context root is /webapp/MyServlet.In Servlet mapping URL Pattern is /MyServlet.I installed the Application.When I try to view MyServlet using http://localhost:9080/webapp/MyServlet/MyServlet I am getting following error. Error 500: Failed to load target servlet [MyServlet] In the log file it is saying Failed to load servlet�java.lang.NoClassDefFoundError: MyServlet (wrong name: webapp/MyServlet)Can anybody please help in solving this? Your help is greatly appreciated.
 
"The Hood"
Posts: 8521
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Moving to Servlets.
 
Consider Paul's rocket mass heater.
    Bookmark Topic Watch Topic
  • New Topic