• Post Reply Bookmark Topic Watch Topic
  • New Topic

RunTime Error.  RSS feed

 
Sathish Ramadas
Greenhorn
Posts: 27
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Actually i am using welogic jdk for the production environment (Linux). I am creating the PDF files using iText api. When i try to use new Color(,,,) awt constructor it gives me this error. but at the same time when i use the same code with sun's jdk then it works fine.

pls advice me to proceed wiht the weblogic environment.

java.lang.UnsatisfiedLinkError: /opt/beajrockit/8.1.SP2LB2/jre/lib/i386/libawt.so: /lib/i686/l
at java.lang.ClassLoader$NativeLibrary.load(Ljava.lang.String I(Native Method)
at java.lang.ClassLoader.loadLibrary0(Ljava.lang.Class;Ljava.io.File Z(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Ljava.lang.Class;Ljava.lang.String;Z)V(Unknown Source)
at java.lang.Runtime.loadLibrary0(Ljava.lang.Class;Ljava.lang.String V(Unknown Source)
at java.lang.System.loadLibrary(Ljava.lang.String V(Unknown Source)
at sun.security.action.LoadLibraryAction.run()Ljava.lang.Object;(LoadLibraryAction.java:50)
at java.security.AccessController.doPrivileged(Ljava.security.PrivilegedAction Ljava.lang.Object;(Native Method)
at java.awt.Toolkit.loadLibraries()V(Toolkit.java:1401)
at java.awt.Toolkit.<clinit>()V(Toolkit.java:1422)
at COM.jrockit.vm.RNI.toNative(I)I(Native Method)
at COM.jrockit.vm.RNI.trampoline()V(Native Method)
at java.awt.Toolkit.loadLibraries()V(Toolkit.java:???)
at java.awt.Color.<clinit>()V(Color.java:250)
at COM.jrockit.vm.RNI.toNative(I)I(Native Method)
at COM.jrockit.vm.RNI.clinitTrampoline()V(Native Method)
 
David Ulicny
Ranch Hand
Posts: 724
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
There is no native implementation of this method.
 
Ian Darwin
author
Ranch Hand
Posts: 64
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
java.lang.UnsatisfiedLinkError: /opt/beajrockit/8.1.SP2LB2/jre/lib/i386/libawt.so: /lib/i686/l...

Check BEA's web site for support; either the development kits isn't installed
correctly or your classpath has gotten messed up.

Ian
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!