• Post Reply Bookmark Topic Watch Topic
  • New Topic

HotSpot Virtual Machine Error  RSS feed

 
Sam Egbert
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I get the following error while running a Java application on Windows XP. Has anybody encountered this same problem?

Thanks in advance for your help.

#
# HotSpot Virtual Machine Error, Internal Error
# Please report this error at
# http://java.sun.com/cgi-bin/bugreport.cgi
#
# Java VM: Java HotSpot(TM) Client VM (1.4.2-b28 mixed mode)
#
# Error ID: 43113F32554E54494D45110E4350500308
#
# Problematic Thread: prio=5 tid=0x02e40048 nid=0xad0 runnable
#

Heap at VM Abort:
Heap
def new generation total 9216K, used 1208K [0x10010000, 0x10a00000, 0x1277000
0)
eden space 8256K, 14% used [0x10010000, 0x1013e150, 0x10820000)
from space 960K, 0% used [0x10910000, 0x10910000, 0x10a00000)
to space 960K, 0% used [0x10820000, 0x10820000, 0x10910000)
tenured generation total 121024K, used 37365K [0x12770000, 0x19da0000, 0x3001
0000)
the space 121024K, 30% used [0x12770000, 0x14bed6d0, 0x14bed800, 0x19da0000)

compacting perm gen total 22784K, used 22563K [0x30010000, 0x31650000, 0x34010
000)
the space 22784K, 99% used [0x30010000, 0x31618e58, 0x31619000, 0x31650000)
Press any key to continue . . .
 
Sanj Sharma
Ranch Hand
Posts: 32
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
We got this error when running code that made extensive
uses of arrays and files. The code was compiled on the 1.2
JVM. The error message appears if you try and run it against
the 1.3 or 1.4 JVM's on Windows. The error does not occur if
you compile under 1.4. In addition to the "HotSpot Virtual
Machine Error, Internal Error" message the application might
simply vanish or produce the Microsoft "Send us your bug"
window.
 
Sam Egbert
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Thanks for your response.

I am actually running my application within the latest version of JBoss Application Server. I am pretty sure this version of JBoss was compiled using JVM 1.4. I will do some more investigating to make sure.
 
Sam Egbert
Greenhorn
Posts: 12
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I noticed that this error occured every time any method was call on a specific class. After some further investigation I realized that this class was deployed in both .war and .jar files. I removed it from the .war file and the error no longer occurs.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!