• Post Reply Bookmark Topic Watch Topic
  • New Topic

Tiger's for-each construct  RSS feed

 
nag potlup
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi,
do i need to have jdk 5.0 to let my eclipse IDE support j2se 5.0's language features?...I'm asking this becoz my eclipse recognized 5.0's new 'for-each' construct when all i had is jre 5.0 and j2sdk 1.4.2_12.

thanks,
 
Jesper de Jong
Java Cowboy
Sheriff
Posts: 16060
88
Android IntelliJ IDE Java Scala Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Eclipse has its own built-in Java parser and compiler. If you set the IDE to Java 5.0, it will recognise Java 5.0 code even if you don't have Java 5.0 installed. But that doesn't mean all of your code will run on Java 1.4.2.
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!