• Post Reply Bookmark Topic Watch Topic
  • New Topic

MultipleJRE's  RSS feed

 
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have created an app in Netbeans using SDK 1.4.2. The machine I am going to be running it on has jre 1.4.2 and jre 1.5.0. My boss wants me to ensure that it runs on JRE 1.4.2, is there anyway in my code I can ensure this or will the app automatically pick up 1.4.2 seeing as it was developed in JDK 1.4.2.
 
Java Cowboy
Sheriff
Posts: 16060
88
Android IntelliJ IDE Java Scala Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
No, it will not automatically run on JRE 1.4.2.

Just make sure you start the right java.exe. Make a batch file to start your application and add a command like this in it:

c:\j2re1.4.2\bin\java.exe com.mypackage.MyMainClass

(i.e., just specify the complete path to the java.exe of JRE 1.4.2).
 
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!