Win a copy of Functional Reactive Programming this week in the Other Languages forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

HelloWorld not working

 
William Barnes
Ranch Hand
Posts: 986
Eclipse IDE Firefox Browser Tomcat Server
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
This code worked at work, than I moved it to my ISP and it didn't work. My ISP account will not let me run CGI - is that in anyway related? In my browser I see the "Hello test header" message, but getting the message "Applet HelloWorld class could not be loaded" in the status bar on the bottom. (Yes, I have a HelloWorld.class file in the same directory.) Thanks.
$> cat Hello.html
< !DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
<html>
<head>
<title>Hello test page.</title>
</head>
<body>
<h1>Hello test header.</h1>
<applet code="HelloWorld.class" width=300 height=50> </applet>
</body>
</html>
$> cat HelloWorld.java
import java.applet.Applet ;
import java.awt.Graphics ;
public class HelloWorld extends Applet
{
public void paint( Graphics g)
{
g.drawString("Hello world!", 50, 25) ;
}
}
 
jatin rai
Greenhorn
Posts: 11
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

try working out this! take look at the bold secyion.
$> cat Hello.html
< !DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">
applet codebase="[your current directory!]" code="HelloWorld.class" width=300 height=50
Hope this helps your cause & if not please tell me & I'll try something else.
all the best
bye

[This message has been edited by jatin rai (edited July 08, 2001).]
[This message has been edited by jatin rai (edited July 08, 2001).]
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic