• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

JDK 1.4 tools for J2ME?

 
Michael Yuan
author
Ranch Hand
Posts: 1427
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
The MIDP for Palm "preverify" program does not seem to work with JDK 1.4 tools. It complains the following when I try to pre-verify classes.

Error preverifying class XMLDsig.Utils
Class loading error: Illegal constant pool index

It works with no problem if I change JAVA_HOME back to jdk1.3.1/
Any ideas?
 
Thomas Paul
mister krabs
Ranch Hand
Posts: 13974
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Doesn't this belong in the J2ME forum?
 
Michael Yuan
author
Ranch Hand
Posts: 1427
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Yeah, but since the JDK1.4 book author Ivor is hanging around here, I guess this forum will bring more JDK 1.4 experts.
 
Valentin Crettaz
Gold Digger
Sheriff
Posts: 7610
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I've had the exact same problem a while ago. The documentation on the Sun's wireless toolkit web page states under "Required Software":
Java 2 Standard Edition, version 1.3 or later
That documentation has been written in October 2000 which is way before J2SE 1.4 was released. So the "or later" really means 1.3 or 1.3.1.
Other related discussions:
http://forum.java.sun.com/thread.jsp?forum=50&thread=214005
http://forum.java.sun.com/thread.jsp?forum=76&thread=226971
 
With a little knowledge, a cast iron skillet is non-stick and lasts a lifetime.
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic