Win a copy of Kotlin for Android App Development this week in the Kotlin forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Liutauras Vilda
  • Devaka Cooray
  • Jeanne Boyarsky
  • Bear Bibeault
Sheriffs:
  • Junilu Lacar
  • Paul Clapham
  • Knute Snortum
Saloon Keepers:
  • Ron McLeod
  • Tim Moores
  • Stephan van Hulst
  • salvin francis
  • Carey Brown
Bartenders:
  • Tim Holloway
  • Frits Walraven
  • Ganesh Patekar

Failed to insert a record into MSAcess  RSS feed

 
Ranch Hand
Posts: 305
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello,
I am trying with the following code to insert a record into the MS Access database...It prints me on system that it has inserted a record but it never did same...Am I doing something wrong or there is some other problem?
I am using following:
1. Windows 2000
2. MS Access 2000
3. JDK 1.3.0 ( also tried with 1.4.0)
To Connect with database
*************************

To insert a record(tried using Preapared and Simple Statement:
*******************

regards,
Arun
 
Rancher
Posts: 13459
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
If you ran a search in the JDBC forum, you'd find that this is a common problem with the JDBC-ODBC bridge.
Solution: either make sure you close the connection, set autocommit(true) before hand, or do a dummy read (ie a search that you don't care about the results of) after the insert or update.
Dave
 
Sheriff
Posts: 7023
 
All of the world's problems can be solved in a garden - Geoff Lawton. Tiny ad:
RavenDB is an Open Source NoSQL Database that’s fully transactional (ACID) across your database
https://coderanch.com/t/704633/RavenDB-Open-Source-NoSQL-Database
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
Boost this thread!