This week's book giveaway is in the HTML Pages with CSS and JavaScript forum.
We're giving away four copies of Testing JavaScript Applications and have Lucas da Costa on-line!
See this thread for details.
Win a copy of Testing JavaScript Applications this week in the HTML Pages with CSS and JavaScript forum!
  • Post Reply Bookmark Topic Watch Topic
  • New Topic
programming forums Java Mobile Certification Databases Caching Books Engineering Micro Controllers OS Languages Paradigms IDEs Build Tools Frameworks Application Servers Open Source This Site Careers Other all forums
this forum made possible by our volunteer staff, including ...
Marshals:
  • Campbell Ritchie
  • Bear Bibeault
  • Ron McLeod
  • Jeanne Boyarsky
  • Paul Clapham
Sheriffs:
  • Tim Cooke
  • Liutauras Vilda
  • Junilu Lacar
Saloon Keepers:
  • Tim Moores
  • Stephan van Hulst
  • Tim Holloway
  • fred rosenberger
  • salvin francis
Bartenders:
  • Piet Souris
  • Frits Walraven
  • Carey Brown

What is the deal with Java Applets on WIndows XP?

 
Ranch Hand
Posts: 237
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It seems like I should know this - but apparently this was lacking somewhere in my Java education.
Background information:
I am using Windows XP on my home computer. My questions below relate to my use of Java on my home computer. I have correctly installed:
JDK1.3.1
JDK1.4.0
J2SDKEE1.3.1
J2SDKEE1.2.0
TOMCAT Version 3.2.3
TOMCAT Version 4.0
I have successfully been using various versions of Tomcat and various versions of Java. I passed the SCWCD Exam last week. But I guess I don't understand java applets!
Question 01:
How can I tell if the Java 1.4 Applet plugin is correctly installed on my computer? What file folder does this reside on? What is the default install location for Java Applet classes?
Question 02:
Is it true that if the JDK1.4.0 is correctly installed and working, that means that the Applet Plugin was also installed?
Question 03:
Is there something within WIndows XP that is supposed to be "set" somewhere that has to do with Java Applets?
The deal is, I have an applet that specifically needs the Java 1.4.0 "applet plugin". I can't get it to work, so I am assuming at this point that I don't have the Java Applet 1.4.0 correctly running.
Within the options for Internet Explorer(Version 6.2), I checked the box for:
____ Java Console Enabled (restart required)
____ Java Loggin Enabled
I then restarted my computer. But it did not correct the issue. I still can not run any applets.
thanks!
Kevin Thompson
[ August 12, 2002: Message edited by: Kevin Thompson ]
 
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
How can I tell if the Java 1.4 Applet plugin is correctly installed on my computer?
View this applet:
Is it true that if the JDK1.4.0 is correctly installed and working, that means that the Applet Plugin was also installed?
No.
Is there something within WIndows XP that is supposed to be "set" somewhere that has to do with Java Applets?
During the installation of the Java SDK, the JRE is installed, and you should have had the option to use the Java 2 plug-in with IE. Otherwise, you have a couple of strategies to enable the Java 2 plug-in for use with IE.
1. Within IE: Tools -> Options -> Advanced -> Under Sun/Java Category select use Java 2 plug-in
2. Control Panel -> Java Plug-in Control Panel -> Browser Tab -> select IE
Any luck?
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Note that it's possible and reasonable to have the 1.4 plug-in installed properly but use Java 1.1 support by default. Then, when an applet is written for Java 2, the developer must use the proper tag in the html page to tell your browser to use the Java 2 plug-in rather than anything else.
 
Ranch Hand
Posts: 15304
6
Mac OS X IntelliJ IDE Chrome
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator

Originally posted by Dirk Schreckmann:
...the developer must use the proper tag in the html page to tell your browser to use the Java 2 plug-in rather than anything else.



Dirk, could you elaberate on this a little, or possibly answer my post here :
https://coderanch.com/t/254734/Applets/java/Applet-Tag-Options
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Elaborate? You asked for it. Take a look at Exploring Browser Support for Java 2.
The solution presented by Marilyn (version 02c) would seem to be the best one. I don't know how she came up with it, she still hasn't told us.
[ August 12, 2002: Message edited by: Dirk Schreckmann ]
 
Kevin Thompson
Ranch Hand
Posts: 237
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Dirk: Thanks!
I downloaded the Java Plugin 1.4.01 from Sun. It installed the applet files in C:/Program Files/Java.
I can now run the applet in question from an internet site, and also stand alone on my computer.
I don't know why I thought JDK1.4.0 automatically included plugins.
thanks again,
Kevin Thompson
 
Dirk Schreckmann
Sheriff
Posts: 7023
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I don't know why I thought JDK1.4.0 automatically included plugins.
It has been my experience, that the Java SDK 1.4 installation does optionally install the Java 2 plug-in for selected browsers (IE or Netscape 6).
 
I knew I would regret that burrito. But this tiny ad has never caused regrets:
Thread Boost feature
https://coderanch.com/t/674455/Thread-Boost-feature
    Bookmark Topic Watch Topic
  • New Topic